Page 1 of 1

Can't host with new Fritz Box Router

Posted: Mon Sep 25, 2017 12:19 pm
by B1tchFight
Hey guys, I recently changed my Internetspeed from 100mbit/s to 400mbit/s and therefore I got a new Router. Just a newer version of the one I already had. I went into the settings set up every portforwarding as usual. The funny thing is that I can host standard multiplayer games (even if it shows the overall hated R.I.P) I just can't host scenarios. I also changed the names in my scenario to to able to play in a online MP game with my friend. He joined my game but he couldn't download the file from me (because of the connection) I sent the file to him to put into the save game folder and it still wants to download it from my and stucks at 0% :/

Any idea how I can get it back to work as usual? Tested Firewall and Windows Defender as well. I could player weeks before I changed the router. So I think it might be related to it.

Edit: The important part about scenarios is, that this is a usual save file. Means with your NAT tech to host even without ping you can't continue a save game unless all player have the same file. The client won't download the file without a ping... grrr

Re: Can't host with new Fritz Box Router

Posted: Mon Sep 25, 2017 1:11 pm
by Jodocus
Hi. The fact that you can host standard games is due to the RIP hosting technique (NAT traversal) I added to NeoEE. Unfortunately, doing this for scenario games as well is quite hard and I don't know yet how and if I can do that.
Check your private IP in your forwarding rules. It has to be your private/local network IP address. Also, try to find out whether you got an IPv6 internet connection via DS Lite. DS Lite is getting more and more common and it effectively makes port forwarding impossible.

Re: Can't host with new Fritz Box Router

Posted: Tue Sep 26, 2017 1:07 am
by B1tchFight
Thanks for the reply. I am a technical guy and used to solve a lot of these problems. I understand the mechanic. Like I said. I set it up as usual. Right port, right local IP and also tried UPnP. Interesting fact ist that UPnP won't open all 5 ports... Anyway... I switched to the IPv6 Setting and used Port forwarding there. I restarted my PC + Internet afterwards and now I get a Ping in a few games... Like 1 out of 10 has a ping.

Anyway... Hosting Scenarios works with a little trick. If you know the guys you want to play with (luckily there are not a lot) you can uses your .ees name changer and put the online Player names in there and sent the file to them via FTP or what ever. It's a lot of work but at least it works.

And yes, I am connected via IPv6. What do you mean by "DS Lite" Is there no way to circumvent this? I might call my provider later to see if there is anything they can do. If I can't portforward anymore I can forget every single game I used to play via tunngle as well... :-/

Edit:Problem solved. I contacted the Router manufacture and he told me the same about DS Lite as you did. I called my provider and he gave me an IPv4 without any discussion. :-) A few hours later my router restarted and now I have a 6 month static IPv4 again :) Thanks again for this DS Lite hint!