Crashing on splash

If you're having any technical difficulties with EE, or installing or using the lobby, make a post here and someone will try and help you out.
Posts: 1
Joined: Thu May 31, 2018 10:39 pm

Crashing on splash

Post by adamsvette »

I loved this game and have spent hours of my childhood playing it and want nothing more than to just get it working.

It was working on a windows 7 laptop and then I upgraded to windows 10 and it stopped working. Crashed on splash. Tried installing it on a brand new Windows 10 desktop and had the same problem. So I bought it on GOG thinking that it would work better than a cd version and had the same problem. I also tried the EE-Forever method listed here:


I've even tried installing EE on a windows xp virtual machine using EE-forever and GOG installer files and I'm getting the same "crash on splash."

I've spent probably 50-100 hours reading forum after forum post on all the different problems people have with this game but I can't find a fix for "crash on splash".

Windows 10 Home
24 gigs of RAM
Nvidia GeForce GT 730

Any help will be much appreciated. Also, I don't have access to the CD atm so please assume I can only use internet links and my GOG version of my installer.

NeoEE Developer
Posts: 244
Joined: Mon Nov 11, 2013 9:24 am
Lobby Username: Jodocus

Re: Crashing on splash

Post by Jodocus »


if you know how, try to delete any registry key of EE and try to start it then again. Sometimes this helped. Usually, it's something at HKLM\Software\Sierra and/or HKLM\Software\SSSI\Empire Earth and alike. Good luck!


Return to “Support”

Who is online

Users browsing this forum: No registered users and 4 guests