Performance Fix

Talk about anything EE related and doesn't belong in another forum. Gameplay, chit-chat, or any questions you have -- it all belongs here.
Post Reply
Posts: 1
Joined: Wed Aug 16, 2023 2:35 am

Performance Fix

Post by ELKR »

empire earth performance is greatly effected by in-game resolution and timers.
1. In-game Use 1080p. In dgVoodoo2 Use Stretched, keep Aspect Ratio(General tab) and 2x or 4x Resolution (DirectX tab)
2. !!!CAUTION!!! run command prompt as admin to switch timers to PMT + RTC: bcdedit /set useplatformclock Yes bcdedit /set useplatformtick Yes make sure HPET is disabled in BIOS.

Using the ancient PMT + RTC timers can fix old games but can cause issues in modern applications, and mice set to high polling rates. Change at your own risk.
To use default modern timers again: TSC + TSC without desync: bcdedit /deletevalue useplatformclock - bcdedit /deletevalue useplatformtick - make sure HPET is enabled in BIOS

I got the game running in 8k pretty smooth on my 1080ti and 1600x.

In dgVoodoo2 I have Resolution 4x with stretched keep aspect ratio scaling, and in-game I have 1920x1080x32 selected.

I get 20fps if I choose 3840x2160x32 in-game whether native or scaled 2x.
I get 40~60fps if I choose 1920x1080x32 in-game whether native, scaled 2x, or scaled 4x.
I assure you it's working. 1080p native looks incredibly blurry on my 55"4k TV and 1080p scaled 4x looks insanely crisp.

However most people experimented with dgVoodoo settings and figured this out.

I noticed the game had some kind of fps capping even with vsync off. The game would look incredibly choppy like it was getting much less FPS than reported. Many old FPS limiters are broken by modern timers. I switched over to the old timers by entering
bcdedit /set useplatformclock Yes
bcdedit /set useplatformtick Yes
into an administrative elevated command prompt, restarting my PC into BIOS to disable HPET, and restarted to confirm new bios settings.
Some info on timers: ... et-tsc-pmt

The game is smooth now. Reported FPS feels correct and fluctuates naturally (i.e. 51,50,49,48,477 instead of strictly 48,30,24[can't recall exact numbers]). Insane amount of mouse input is gone.

Too bad this isn't a fix that you can incorporate into NeoE, but for those of us who love this game the annoying back and forth of enabled and disabling this tweak is worth it.

and too bad I can't upload a 4k screenshot. File is too large.

Post Reply

Return to “EE General Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests